Incident on Coyote Fleet

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 21:00 CEST

Monitoring

The incident is resolved. This followed a failed maintenance operation. All tests performed in the test environment were satisfactory.
Posted Jun 02, 2026 - 12:16 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 02, 2026 - 11:37 CEST
This incident affected: Customer Services - Fleet B2B (Customer access to the Fleet Connect application).